Project

General

Profile

Bug #10797

editing in dr, 6c23073, crashed

Added by Patrick Shanahan about 4 years ago. Updated over 3 years ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
Start date:
12/20/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
git development version
System:
openSUSE
bitness:
64-bit
hardware architecture:
amd64/x86

Description

editing in darkroom and crashed
believe I was selecting area to crop

6c23073
bt @ http://wahoo.no-ip.org/~pat/darktable_bt_H2519X.txt

darktablerc (21 KB) darktablerc Patrick Shanahan, 12/20/2015 03:08 PM
151205_131702_dsc_0806.nef.xmp (6.21 KB) 151205_131702_dsc_0806.nef.xmp Patrick Shanahan, 12/20/2015 03:13 PM
151205_131702_dsc_0806.nef (28.2 MB) 151205_131702_dsc_0806.nef representative image Patrick Shanahan, 12/20/2015 03:14 PM
dt.control.dbug.txt (227 KB) dt.control.dbug.txt darktable -d control output Patrick Shanahan, 12/20/2015 03:22 PM

History

#1 Updated by Ulrich Pegelow about 4 years ago

Can you supply an input image + XMP please?

If you can reproduce the crash, please test if it also occurs with commit c4280c42b7a4c9a54a21672f49fc62890a2944a7.

From the backtrace it looks like an error triggered in the tiling code by an invalid roi value (negative image width). But already the roi_in that leads to that processing step looks suspicious: roi_in = {x = 34, y = 0, width = 1, height = 1, scale = 1}.

#2 Updated by Roman Lebedev about 4 years ago

Can you please also upload your ~/.config/darktable/darktablerc ?

#3 Updated by Roman Lebedev about 4 years ago

The problem here starts here:

#67 0x00007f1d39726185 in dt_dev_process_image_job (dev=0x30eda80) at /usr/src/debug/darktable-2.0+git1450544563.6c23073/src/develop/develop.c:383
        buf = {size = DT_MIPMAP_FULL, imgid = 134236, width = 6016, height = 4016, buf = 0x7f1c8cac5060 "\242\004\031\t\260\004\310\b\246\004\224\b\205\004\214\b\221\004u\b\210\004H\b\215\004\210\b\227\004S\b\234\004\234\b\216\004\262\b\223\004\271\b\247\004\344\b\276\004\367\b\260\004%\t\270\004(\t\310\004\\\t\316\004\236\t\320\004\362\t\353\004\062\n\352\004F\n\367\004}\n\367\004\263\n\a\005\356\n\374\004\337\n;\005\337\n\025\005\314\n\022\005;\v\r\005\025\v!\005\066\v\"\005\033\v-\005!\v\022\005+\v\f\005\021\v\t\005\372\n(\005?\v-\005\024\v4\005\032\v>\005S\v\v\005.\v\f\005\377\n\030\005", color_space = DT_COLORSPACE_NONE, pre_monochrome_demosaiced = 0, cache_entry = 0x7f1cec027700}
        start = {clock = 159962554.87089899, user = 1681.768}
        zoom = <optimized out>
        zoom_x = 0
        zoom_y = 0
        scale = 1025
        window_width = <optimized out>
        window_height = <optimized out>
        x = 0
        y = 0
        closeup = <optimized out>
        pipe_changed = <optimized out>
        wd = 1025
        ht = 1025


scale = 1025 <- i do not see any sane way why it can be that big. it should not bigger than 2 (plus probably some high-dpi stuff)

#4 Updated by Roman Lebedev about 4 years ago

Patrick Shanahan wrote:

6c23073
bt @ http://wahoo.no-ip.org/~pat/darktable_bt_H2519X.txt

Please start dt with -d control, and show the output.
I'm most interested in output from this code block (gui->ppd value): https://github.com/darktable-org/darktable/blob/851369753c3a898d3c5f50d0711db4ab589f5e53/src/gui/gtk.c#L970-L1023

#5 Updated by Patrick Shanahan about 4 years ago

I do not know which image caused or was active during the crash but I have
uploaded 151205_131702_806.nef + xmp

I cannot reproduce, it has not occurred again. The commit is not available
(compiled) for my system. I use darix' builds.

~/.config/darktable/darktablerc is uploaded

Output from "darktable -d control" for a complete cycle working an image is
uploaded, dt.

#6 Updated by Pascal Obry about 4 years ago

  • Status changed from New to Closed: invalid

Ok, I'm closing then if it cannot be reproduced now. Please send further info here if it occurs again.

#7 Updated by Roman Lebedev over 3 years ago

  • Target version set to 2.2.0

Also available in: Atom PDF

Go to top