Project

General

Profile

Bug #10786

Visual glitch when moving sliders

Added by Joe Giampaoli over 4 years ago. Updated over 3 years ago.

Status:
Closed: upstream
Priority:
Low
Assignee:
-
Category:
General
Target version:
Start date:
12/16/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0rc4
System:
Debian
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I just wanted to report that since using version 3 I've noticed a momentary visual glitch when changing values or moving sliders in modules. I think it's the pop-up with the hints and tips that suddenly draws colored icons, but it disappears immediately so it's impossible to get a screenshot of that and it doesn't always happen. Not the biggest deal but it does kind of distract. Just updated to rc4 with same issue.

Thanks

out.ogv (1.45 MB) out.ogv Joe Giampaoli, 12/29/2015 12:25 AM
Screenshot - 12282015 - 04_27_37 PM.png (58.9 KB) Screenshot - 12282015 - 04_27_37 PM.png Joe Giampaoli, 12/29/2015 12:30 AM
out2.ogv (2.38 MB) out2.ogv Joe Giampaoli, 01/04/2016 12:04 AM

Related issues

Related to darktable - Bug #10979: Fullscreen mode editing glitches when activating OpenCL, Ubuntu 15.10 New04/03/2016

Has duplicate darktable - Bug #10876: import camera tooltip flickersClosed: upstream01/15/2016

History

#1 Updated by Joe Giampaoli over 4 years ago

I was able to do a screen capture in video so you can see what I get when changing values in modules. It looks to me like it shows some of my desktop environment taskbar icons.

#2 Updated by Joe Giampaoli over 4 years ago

Should of thought about screencapturing the video at that very glitch. Anyway, here it is. Those icons are at the top of my screen in a taskbar, you can clearly see my Debian menu and other icons I have next to it. So it's picking that up

#3 Updated by Tobias Ellinghaus over 4 years ago

  • % Done changed from 0 to 20
  • Status changed from New to Incomplete

That looks like a bug in your xserver, window manager or some other part of the stack. Do you use compositing (fancy window effects, transparency, ...)? Does this still happen if you turn it off? Do you get errors like that in other Gtk3 applications?

#4 Updated by Joe Giampaoli over 4 years ago

Tobias Ellinghaus wrote:

That looks like a bug in your xserver, window manager or some other part of the stack. Do you use compositing (fancy window effects, transparency, ...)? Does this still happen if you turn it off? Do you get errors like that in other Gtk3 applications?

Correct! I do have compositing on for some specific things I use (I'm not a fan of too much of fancy visuals), turned it off just now to test and same problem with the same levels module. No, I do not have this same glitches in other programs now that I think of it. Just to let you know, my desktop environment (or window manager) is XFCE. I am using official Nvidia drivers from the website, not from Debian.

Thanks

#5 Updated by Joe Giampaoli over 4 years ago

If by any chance this can't be fixed, is there a way to turn pop-ups off? Or maybe compile without it?

#6 Updated by Tobias Ellinghaus over 4 years ago

I am not aware of any way to turn them off/compile without them short of patching GTK. Could you maybe try with another driver? I am quite sure that it's not a bug in darktable.

#7 Updated by Joe Giampaoli over 4 years ago

Well, strangely it's not doing it right now (just checked this very moment) somehow it stopped, but it was very easy to reproduce. I am using DT revision-619c8fe5 at the moment. Also two days ago I was fooling around with my Debian installation and decided to give Cinnamon a try which runs I believe with Gnome Shell to see if I liked that environment. I "sort" of liked it but already removed it, I'm too old school maybe heh! What I did notice was that I did fire up DT in it and never experienced that visual glitch. I also updated NVIDIA yesterday, but that was already after I tried DT in Cinnamon without that glitch. So, I think this is more of an XFCE thing, not a Darktable problem like you say. Now that it's not doing it anymore, I wonder if when I installed Cinnamon and removed it, it probably tinkered with some config file, maybe even in my home dir? Who knows. I'll keep my eyes open and see if it comes back. One thing I didn't try and I will if it does come back is using DT in full screen mode, because that glitch was rendering objects in my XFCE panel, so let's see what happens. These kind of glitches don't drive me 100% nuts as long as they are functional, but somebody down the road might come up with the same bug and some people are more picky about these type of things.

Thanks again and I'll let you know if it comes back and I'll do further testing. Or maybe even try to resurrect it if I can, then maybe we'll figure out what was causing it.

Cheers!

#8 Updated by Joe Giampaoli over 4 years ago

Just so you can see how it responds now. What I do notice is that the pop-up with the information of the tool will still "pop up" while dragging the slider, maybe it would be a good idea to disable it once there's user interaction?

Thanks

#9 Updated by Tobias Ellinghaus over 4 years ago

  • % Done changed from 20 to 0
  • Status changed from Incomplete to Closed: upstream

Those are handled by GTK darktable doesn't draw them. I'm closing here for the time being, feel free to reopen if you have any new insight.

#10 Updated by Roman Lebedev about 4 years ago

  • Has duplicate Bug #10876: import camera tooltip flickers added

#11 Updated by Roman Lebedev about 4 years ago

  • Related to Bug #10979: Fullscreen mode editing glitches when activating OpenCL, Ubuntu 15.10 added

#12 Updated by Roman Lebedev over 3 years ago

  • Target version changed from Candidate for next major release to 2.2.0

Also available in: Atom PDF

Go to top