Project

General

Profile

Bug #10679

Re-applying 1 star rating will unrate photo

Added by Phillip Anderson over 3 years ago. Updated over 2 years ago.

Status:
Fixed
Priority:
Low
Assignee:
-
Category:
Lighttable
Target version:
Start date:
10/22/2015
Due date:
% Done:

100%

Affected Version:
git stable branch
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Trying to apply a 1-star rating to a photo that is already rated 1-star will unrate the photo. This can lead to photos that are unrated by accident.

Select (or hover) any photo in lighttable mode.
Press 1 to give it a 1-star rating.
Press 1 again, and it reverts to 0-stars.

All other ratings (r, 0, 2-5) behave appropriately, i.e., pressing 2 rates the photo 2-stars regardless of current rating.

I'm currently using Darktable 1.6.9 from the stable PPA

History

#1 Updated by Tobias Ellinghaus over 3 years ago

  • Status changed from New to Closed: invalid

That's by design. I don't like it either, but well ...

#2 Updated by Phillip Anderson over 3 years ago

Ah ok, hadn't realized that. That behavior is a bit non-intuitive, as I imagine you'd agree if you also do not like it. Do you know what the rationale/use case was for making it this way instead of consistent with the other rating levels?

#3 Updated by Roman Lebedev over 2 years ago

  • % Done changed from 0 to 100
  • Target version set to 2.4.0
  • Status changed from Closed: invalid to Fixed

Also available in: Atom PDF