Project

General

Profile

Feature #10664

Allow thumbnailing images at import

Added by Victor Lamoine over 4 years ago. Updated over 4 years ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
Category:
Lighttable
Target version:
-
Start date:
10/13/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
1.6.8
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Not sure the title is explicit, feel free to rename.

When importing files in darktable, thumbnails are generated and cached.
However only the thumbnails of the visible files in the lightroom are generated.

This means that for a big set of files when the user scrolls he has to wait for the thumbnail to be generated. I find this very annoying and would prefer that all thumbnails are generated during the import process.
Maybe an option "generate thumbnails at import" would be appropriate? This would increase import time but improve usability.

I embedded a little video to illustrate the feature request; at 15 secs you can see that when scrolling the thumbnails are missing and thus being generated.
I would like these to be generated at import time.

thumbnail.mp4 (3.69 MB) thumbnail.mp4 Video showing thumbnails generation Victor Lamoine, 10/13/2015 07:53 PM

Related issues

Is duplicate of darktable - Feature #8823: Thumbnail generation should continue in backgroundFixed07/10/2012

History

#1 Updated by Roman Lebedev over 4 years ago

  • Is duplicate of Feature #8823: Thumbnail generation should continue in background added

#2 Updated by Roman Lebedev over 4 years ago

  • Status changed from New to Duplicate

With New^2 (current) thumbnail cache you can now run
$ darktable--generate-cache
and it will generate thumbnails for all the (currently available) images in the cache.

#3 Updated by Tobias Ellinghaus over 4 years ago

That's of course darktable-generate-cache.

Also available in: Atom PDF

Go to top