Project

General

Profile

Bug #10645

User manual's compilation failed

Added by Michel Leblond over 3 years ago. Updated over 3 years ago.

Status:
Closed: upstream
Priority:
Low
Assignee:
-
Category:
Usermanual
Start date:
09/28/2015
Due date:
% Done:

0%

Affected Version:
git development version
System:
Debian
bitness:
64-bit
hardware architecture:
amd64/x86

Description

User manual's compilation failed with following error messages (debian stretch, gcc version 5.2.1 20150911 (Debian 5.2.1-17)) :

[100%] Building fr usermanual
Making portrait pages on A4 paper (210mmx297mm)
Exception in thread "main" java.lang.NoSuchMethodError: org.apache.xmlgraphics.xmp.Metadata.mergeInto(Lorg/apache/xmlgraphics/xmp/Metadata;)V
at org.apache.fop.render.pdf.PDFRenderingUtil.renderXMPMetadata(PDFRenderingUtil.java:356)
at org.apache.fop.render.pdf.PDFDocumentHandler.handleExtensionObject(PDFDocumentHandler.java:290)
at org.apache.fop.render.intermediate.util.IFDocumentHandlerProxy.handleExtensionObject(IFDocumentHandlerProxy.java:197)
at org.apache.fop.render.intermediate.IFRenderer.startPageSequence(IFRenderer.java:519)
at org.apache.fop.area.RenderPagesModel.startPageSequence(RenderPagesModel.java:97)
at org.apache.fop.layoutmgr.PageSequenceLayoutManager.activateLayout(PageSequenceLayoutManager.java:104)
at org.apache.fop.area.AreaTreeHandler.endPageSequence(AreaTreeHandler.java:267)
at org.apache.fop.fo.pagination.PageSequence.endOfNode(PageSequence.java:128)
at org.apache.fop.fo.FOTreeBuilder$MainFOHandler.endElement(FOTreeBuilder.java:347)
at org.apache.fop.fo.FOTreeBuilder.endElement(FOTreeBuilder.java:181)
at org.apache.xalan.transformer.TransformerIdentityImpl.endElement(TransformerIdentityImpl.java:1102)
at org.apache.xerces.parsers.AbstractSAXParser.endElement(Unknown Source)
at org.apache.xerces.xinclude.XIncludeHandler.endElement(Unknown Source)
at org.apache.xerces.impl.XMLNSDocumentScannerImpl.scanEndElement(Unknown Source)
at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(Unknown Source)
at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
at org.apache.xalan.transformer.TransformerIdentityImpl.transform(TransformerIdentityImpl.java:485)
at org.apache.fop.cli.InputHandler.transformTo(InputHandler.java:300)
at org.apache.fop.cli.InputHandler.renderTo(InputHandler.java:130)
at org.apache.fop.cli.Main.startFOP(Main.java:177)
at org.apache.fop.cli.Main.main(Main.java:208)
doc/usermanual/CMakeFiles/darktable-usermanual-fr.dir/build.make:52: recipe for target 'doc/usermanual/darktable-usermanual-fr.pdf' failed
make3: * [doc/usermanual/darktable-usermanual-fr.pdf] Error 1
CMakeFiles/Makefile2:6607: recipe for target 'doc/usermanual/CMakeFiles/darktable-usermanual-fr.dir/all' failed
make2:
[doc/usermanual/CMakeFiles/darktable-usermanual-fr.dir/all] Error 2
CMakeFiles/Makefile2:6615: recipe for target 'doc/usermanual/CMakeFiles/darktable-usermanual-fr.dir/rule' failed
make1:
[doc/usermanual/CMakeFiles/darktable-usermanual-fr.dir/rule] Error 2
Makefile:2367: recipe for target 'darktable-usermanual-fr' failed
make: *
[darktable-usermanual-fr] Error 2

darktable_single-fr.xml Magnifier (956 KB) Michel Leblond, 09/30/2015 10:17 PM

History

#1 Updated by Ulrich Pegelow over 3 years ago

Hi Michel,

did you try with a "fresh" build folder? The following works for me with current master:

rm -r build
./build.sh
cd build/doc/usermanual
make darktable-usermanual-fr

#2 Updated by Michel Leblond over 3 years ago

Hi Ulrich,

I tried what you tell me. This doesn't work ...

I recall the configuration of my machine : debian stretch, gcc version 5.2.1 20150911 (Debian 5.2.1-17)

#3 Updated by Ulrich Pegelow over 3 years ago

There should be a file 'darktable_single-fr.xml' in build/doc/usermanual. Could you upload this file so I can check it?

#4 Updated by Michel Leblond over 3 years ago

I have attached the file 'darktable_single-fr.xml'

#5 Updated by Michel Leblond over 3 years ago

I installed debian 8.2.0 in virtualbox. The compilation does not fail. What is the issue with debian stretch ?

#6 Updated by Ulrich Pegelow over 3 years ago

Looks like there is an issue with your version of fop. On my system I have fop version 1.1 which is part of package xmlgraphics-fop-1.1-16.1.5.noarch.

#7 Updated by Michel Leblond over 3 years ago

fop is provided by a package named fop in debian strecht. Its version is 1.1.dfsg2-2. Its version is 1.1.dfsg2-1 in debian jessie and the compilation does not fail.

#8 Updated by Ulrich Pegelow over 3 years ago

Sounds like an upstream issue.

#9 Updated by Michel Leblond over 3 years ago

The issue is fixed in replacing libxmlgraphics-commons-java version 2.0.1-2 in debian stretch by version 1.5-4 from debian jessie.

#10 Updated by Ulrich Pegelow over 3 years ago

  • Status changed from New to Closed: upstream

Also available in: Atom PDF