Project

General

Profile

Feature #10602

When a file is missing in the raw cache warn about the original file being missing instead

Added by Alex Orange about 4 years ago. Updated almost 3 years ago.

Status:
Fixed
Priority:
Low
Assignee:
Category:
Lighttable
Target version:
Start date:
08/09/2015
Due date:
% Done:

100%

Estimated time:
Affected Version:
1.6.7
System:
other GNU/Linux
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I've tried both darktable-1.6.6 and darktable-1.6.7. Both give the same error. I'm using gentoo. As the subject describes, I select an image, try to export and get:

image `/home/username/.cache/darktable/img-74148afed05c7df306ce8a7abdf62316.JPG' is currently unavailable

I've tried exporting jpegs and pngs, they all give the same message. The folder ~/.cache/darktable exists, I can create files in it just fine, but it's empty.

History

#1 Updated by Pedro Côrte-Real about 4 years ago

It seems like you imported the file /home/username/.cache/darktable/img-74148afed05c7df306ce8a7abdf62316.JPG into your collection and it's no longer there. Can you confirm in the image info that this is indeed the case? Darktable itself doesn't generate files like that.

Importing the darktable cache dir is also a very bad idea but you probably did it by mistake.

#2 Updated by Alex Orange about 4 years ago

No, I imported a different folder that I created under my home directory. I see the images just fine, which I'm not sure how I could do if it was looking for files in the .cache directory.

P.S. I just found out gentoo has a 1.6.8 version and tried that and it also fails.

#3 Updated by Pedro Côrte-Real about 4 years ago

Did you actually check? Looking at the files in the lighttable just requires them to be in the cache, it will still work even after you remove the files from disk. What "full path" is actually shown in the image information tab?

#4 Updated by Alex Orange about 4 years ago

Well, based on your comment about the .cache folder and my messing around I realized that what I did was change the folder name it was in from photos to photo_originals. It would be nice if the error message were meaningful however. I never touched anything in the .cache/darktable folder so I'm not sure why it was complaining about that.

Not sure how to change the title, so if someone could change it to "Filename given in 'image <filename> is currently unavailable' is incorrect" that would be nice.

#5 Updated by Pedro Côrte-Real about 4 years ago

  • Assignee set to Pascal Obry
  • Subject changed from Clicking export does not generate files and see "image ... is currently unavailable" on the command line to When a file is missing in the raw cache warn about the original file being missing instead
  • Tracker changed from Bug to Feature

I did some further digging and what probably happened is that you did local caching for this image (using "copy locally" from the selected images panel). That creates the .cache/img...jpg image. Then you moved the original image and removed the cached copy, so none of the two can be found anymore.

The warning is also sort of correct because the original image is missing (as it would be if it was on removable media) but the cached copy should still exist. It would be nice to warn about the original image though as deleting caches by hand should have no real effect.

#6 Updated by Pascal Obry almost 3 years ago

  • % Done changed from 0 to 100
  • Target version set to Candidate for next major release
  • Status changed from New to Fixed
  • Category set to Lighttable

Should be fixed in master.

#7 Updated by Roman Lebedev almost 3 years ago

  • Target version changed from Candidate for next major release to 2.2.0

Also available in: Atom PDF

Go to top