Project

General

Profile

Bug #10590

Lens recognition under Mac OS X

Added by Alexander Peter over 3 years ago. Updated over 3 years ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
Category:
Buildsystem
Target version:
-
Start date:
07/26/2015
Due date:
% Done:

0%

Affected Version:
1.6.7
System:
Mac OS X
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Hi, not really a bug or a camera support issue. Please move if necessary.

I'm running darktable 1.6.7 on an iMac 10.10.4. un German. I imported some RAW pictures from my Canon EOS 700D with a Tamron SP 70-300 4-5.6 DiVC USD and a Sigma 70-300 4-5.6 DG macro. Unfortunately these lenes are not recognized/translated in the left panel. They show up as "156" (Tamron), and "137" (Sigma).
They are also not recognized within the lens correction tool in the right panel in the editor.
However I can manually adjust at least the Tamron. For the Sigma there's slightly different naming available (DL instead of DG). I also checked both at lensfun,

Afaik darktable uses exiv2. Under Mac this package seems to be included in darktable, as I cannot find it in my Mac terminal... Which version is currently integrated into darktable?
Could you please check and advise. How can I support you?

Alexander

History

#1 Updated by Igor Kuzmin over 3 years ago

  • Assignee set to Igor Kuzmin
  • Status changed from New to Closed: invalid
  • Category set to Buildsystem

exiv2-0.24 was used for 1.6.7 DMG, since it was the latest exiv2 version at that time. 0.25 is out now and will be included in the future DT releases. You can always build DT yourself, see packaging/macosx/BUILD.txt

Also available in: Atom PDF