Project

General

Profile

Bug #10513

DT doesn't quit after minimize, then quit after restore

Added by Josef Rysanek over 4 years ago. Updated over 3 years ago.

Status:
Fixed
Priority:
Low
Assignee:
Category:
-
Target version:
Start date:
06/04/2015
Due date:
% Done:

100%

Estimated time:
Affected Version:
git development version
System:
all
bitness:
64-bit
hardware architecture:
amd64/x86

Description

When quitting DT, DT minimize but never quits (tested with wait about minute with few images). When restored from minimized state, DT restore and finally quit.
Compiled from git master / OS X 10.10. / gtk3 macports.

History

#1 Updated by Tobias Ellinghaus over 4 years ago

  • System changed from Mac OS X to all
  • % Done changed from 0 to 20
  • Status changed from New to Triaged

Same on Linux, though not always. I have to move the mouse over the restored windows. It seems to wait for some GTK signal to fire. Time to move the closing logic out of the display code?

#2 Updated by YAFU YAFU over 4 years ago

I'm a little confused with the title of this report, but I think a similar problem is occurring since a few days in Darktable from master, in Kubuntu 14.04 64bits.
When I close Darktable, it remains in Task Manager (and the process opened) until I click with the mouse in Darktable in the task manager. At that time Darktable closes quickly and in that moment is when the new data the xmp file is saved.

#3 Updated by Josef Rysanek over 4 years ago

Happens on OS X everytime. (it goes to "minimize" state do Dock when quitting but stay forever in that state in Dock and quit only after click on icon in Dock to restore DT from Dock). Hope that confusion is gone.

#4 Updated by YAFU YAFU over 4 years ago

When upgrading from git today (2015-06-29) this problem seems to be solved?
@Josef Rysanek, can you check this?

Edit:
Ok, it is not solved. But I think in my system this problem occurs less frequently now.

#5 Updated by Roman Lebedev over 3 years ago

  • % Done changed from 20 to 100
  • Assignee set to Roman Lebedev
  • Status changed from Triaged to Fixed

I'm mostly sure i fixed that before 2.0 release

#6 Updated by Roman Lebedev over 3 years ago

  • Target version set to 2.2.0

Also available in: Atom PDF

Go to top