Project

General

Profile

Bug #10510

Profiled denoise: Blending "color" with profiled noise reduction creates black image

Added by Sven Greiner over 4 years ago. Updated over 4 years ago.

Status:
New
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
06/03/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
1.6.6
System:
other GNU/Linux
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Using darktable 1.6.6 with profiled noise reduction (wavelet) with blending mode "color" exports a black image. Using "HSV color" works fine.

This issue might be similar to #9882.

System: Arch Linux 64 bit. I've attached the RAW image, its XMP, the exported style and the relevant part of the debug log.


Related issues

Related to darktable - Bug #9882: Black image exported when Shodows&Highlights is used with Profiled Denoise for dark noisy images.Fixed: To be cherry-picked03/31/2014

Related to darktable - Bug #9969: profiled denoise outputs NaNsNew05/26/2014

History

#1 Updated by Sven Greiner over 4 years ago

Attachment of files didn't work. I've uploaded them here now: https://www.dropbox.com/sh/qd4d5kfphy586u8/AAD1pvwcILpJq3U5CPkxXVUPa?dl=0

#2 Updated by Sven Greiner over 4 years ago

Maybe I should mention that I'm using "profiled denoise + color blending" a lot.

Disabling the "shadows and highlights" module fixes the issue.

#3 Updated by Sven Greiner over 4 years ago

Sorry for the noise. Disabling "shadows and highlights" does not fix the issue. Some parts of the image (but not the whole image) are still black.

#4 Updated by Roman Lebedev over 4 years ago

  • Subject changed from Blending "color" with profiled noise reduction creates black image to Profiled denoise: Blending "color" with profiled noise reduction creates black image

#5 Updated by Roman Lebedev over 4 years ago

  • Related to Bug #9882: Black image exported when Shodows&Highlights is used with Profiled Denoise for dark noisy images. added

#6 Updated by Roman Lebedev over 4 years ago

  • Related to Bug #9969: profiled denoise outputs NaNs added

#7 Updated by Sven Greiner over 4 years ago

I have just noticed that the right edge of the image is grayscale! So there really is something wrong in the profiled denoiser.

#8 Updated by Sven Greiner over 4 years ago

Today I had some time and tested various combinations of modules with that image. So what I've noticed:

- Using "HSV color" instead creates an grayscale edge on the right side of the image.
- Using "Color" creates a black edge.
- The full image becomes black because of the propagation of NaN in the shadows+highlights module.
- The problematic edge disappears when I disable the lens correction (distortion) module! Thus everything else works too!
- Happens only for images with 29 mm focal length.

So it seems that something bad happens with the image during the correction of distortion.

To reproduce the black edge use the image from above with:
- Lens correction (distortion only)
- Profiled denoise, wavelet, blending "Color"

Or: Lens correction, profiled denoise, non-local means without blending: Everything will be black, also in preview!

#9 Updated by Sven Greiner over 4 years ago

I found a fix: I increased "scale" in the lens correction module a little bit (was 1.002 by default) so that all visible pixels can be mapped.

Also available in: Atom PDF

Go to top