Project

General

Profile

Bug #10411

Lens not recognized by "lens correction" module

Added by Michele Barp about 5 years ago. Updated about 5 years ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
04/08/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
1.6.4
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

When I open a raw file generated from my Olympus E-PL3 and enable the "lens correction" module, it appears an error telling "camera/lens not found - please select manually".
Examining the "image information" panel in the "lens" line appears a numerical code like 0 0 20 16 0 0. The problem appears also with other olympus raw file downloaded from rawsamples.ch. This bug is not present opening the ooc jpeg.

Other informations:
dpkg -l liblensfun* darktable
ii darktable 1:1.6.4-0pmjdebru amd64 Virtual lighttable and darkroom for photographers
ii liblensfun-data 0.2.8-1pmjdebruij all Lens Correction library - Data
ii liblensfun-dev 0.2.8-1pmjdebruij amd64 Lens Correction library - Development files
ii liblensfun0 0.2.8-1pmjdebruij amd64 Lens Correction library - Runtime files

lens correction.png (18.5 KB) lens correction.png image information Michele Barp, 04/08/2015 12:22 AM
P4076174.ORF (12.3 MB) P4076174.ORF test raw Michele Barp, 04/08/2015 12:27 AM

Related issues

Related to darktable - Bug #10284: Leica DG Summilux 15mm f/1.7 lens is no longer displayed in DTs image information (left side of lighttable) - just some numbers appearFixed01/13/2015

History

#1 Updated by Pascal de Bruijn about 5 years ago

  • Status changed from New to Duplicate

On my system with an updated version of Exiv2, the lens is recognized just fine: "Olympus M.Zuiko Digital ED 40-150mm F4.0-5.6 R"

Current Olympii have two lens fields, LensType is which numeric, and translated by Exiv2 into a string, and LensModel which is a string set by the camera.

Exif.OlympusEq.LensType Byte 6 Olympus M.Zuiko Digital ED 40-150mm F4.0-5.6 R
Exif.OlympusEq.LensModel Ascii 32 OLYMPUS M.40-150mm F4.0-5.6 R

We currently use LensType for old Olympus camera's which don't have the LensModel field, and we're not quite sure if LensModel is even reliable to begin with.

More general information:
http://www.darktable.org/2015/02/on-lens-detection-and-correction/

This issue is also more or less a duplicate of: #10284

#2 Updated by Roman Lebedev about 5 years ago

  • Related to Bug #10284: Leica DG Summilux 15mm f/1.7 lens is no longer displayed in DTs image information (left side of lighttable) - just some numbers appear added

#3 Updated by Michele Barp about 5 years ago

Sorry, but on my system (Ubuntu 14.04) the lens does get recognized using "exiv2 -pt P4076174.ORF | grep -i lens" command, but doesn't get recognized in Darktable. I've tried with a clean installation of Ubuntu 14.04 in a virtual machine but I always get the same results. If this behaviour is normal, maybe because my camera isn't supported anymore, just let me know. Some versions ago (I don't remember from which version the problem arose) the module worked correctly.

Also available in: Atom PDF

Go to top