Project

General

Profile

Feature #10318

EV info in lighttable (image information field)

Added by Francisco Cribari about 4 years ago. Updated about 1 month ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
Category:
Lighttable
Target version:
Start date:
02/10/2015
Due date:
% Done:

0%

Affected Version:
git stable branch
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

FEATURE REQUEST: Would it be possible to add EV (exposure compensation) data to the image information field of lighttable? This is, I believe, an important information. f/4 and f/4 +2/3 EV are quite different. Sometimes the photographer makes two or three shots in, say, aperture priority varying EV and it would be useful to know which photo was made with what EV value. This may not be useful to some photographers but it will certainly be quite useful to many photographers. Please, consider that suggestion.


Related issues

Duplicates darktable - Feature #10066: ability to update date/time New 08/19/2014
Duplicated by darktable - Feature #9674: Show Exposure Bias in Darkroom Duplicate 11/13/2013
Duplicates darktable - Feature #8449: make image information module configurable Triaged

History

#1 Updated by Pascal Obry about 4 years ago

But if the aperture is fixed then the speed vary (or the ISO) so the information is there. The EV can only operate on the speed, the aperture, or the ISO which are the 3 only parameters to get the final exposure. In other words, the EV compensation just does nothing in manual mode. Or am I missing something in your message?

BTW, I'm not saying that this information is not useful, just that it is somehow there.

#2 Updated by Tobias Ellinghaus about 4 years ago

The important question would be, what does an image shot at f/1.8, 1/100s, ISO 100 and +1EV in some auto mode contain in its metadata?

#3 Updated by Francisco Cribari about 4 years ago

My main concern is with photos made in aperture or shutter priority. It would be nice to look at the image information field and see there whether exposure compensation was used. I have to use exiv2 in a terminal window or open the RAW (or exported JPG) file in Gwenview and look at the "Meta Information" field to find out whether or not I used EV in a photo made in aperture priority.

Pascal Obry wrote:

But if the aperture is fixed then the speed vary (or the ISO) so the information is there. The EV can only operate on the speed, the aperture, or the ISO which are the 3 only parameters to get the final exposure. In other words, the EV compensation just does nothing in manual mode. Or am I missing something in your message?

BTW, I'm not saying that this information is not useful, just that it is somehow there.

#4 Updated by Francisco Cribari about 4 years ago

Tobias Ellinghaus wrote:

The important question would be, what does an image shot at f/1.8, 1/100s, ISO 100 and +1EV in some auto mode contain in its metadata?

Here is the exiv2 output of a photo made in aperture priority with -1 EV:

cribari@darwin3:/media/cribari/FC-Ultra-2T/Pictures/raw-2014/09/27-recife-antigo$ exiv2 _FFX4492.RAF
File name : _FFX4492.RAF
File size : 33292800 Bytes
MIME type : image/x-fuji-raf
Image size : 1920 x 1280
Camera make : FUJIFILM
Camera model : X100S
Image timestamp : 2014:09:27 16:22:18
Image number :
Exposure time : 1/850 s
Aperture : F5.6
Exposure bias : -1 EV
Flash : No, compulsory
Flash bias :
Focal length : 23.0 mm
Subject distance:
ISO speed : 250
Exposure mode : Aperture priority
Metering mode : Multi-segment
Macro mode : Off
Image quality : NORMAL
Exif Resolution : 1920 x 1280
White balance : Auto
Thumbnail : image/jpeg, 7548 Bytes
Copyright :
Exif comment :

#5 Updated by Roman Lebedev about 4 years ago

Then i think this issue can be closed as a duplicate of #10066

#6 Updated by Roman Lebedev about 4 years ago

#7 Updated by Roman Lebedev about 4 years ago

  • Duplicated by Feature #9674: Show Exposure Bias in Darkroom added

#8 Updated by Roman Lebedev over 1 year ago

  • Duplicates Feature #8449: make image information module configurable added

#9 Updated by Roman Lebedev over 1 year ago

  • Status changed from New to Duplicate

#10 Updated by Roman Lebedev over 1 year ago

  • Target version set to 2.4.0

#11 Updated by Ari El about 1 month ago

+1. If I may add, other basic metadata info that is missing in the metadata module/panel (darkroom & lighttable) are: Flash (whether it fired or not) and Flash compensation. All for the same reasons requested by OP.

Also available in: Atom PDF