Project

General

Profile

Bug #10315

Add brush to a mask freezes Darktable

Added by Anthony hinsinger over 3 years ago. Updated about 3 years ago.

Status:
Confirmed
Priority:
Low
Assignee:
Category:
Masks
Target version:
-
Start date:
02/08/2015
Due date:
% Done:

10%

Affected Version:
1.6.2
System:
Mac OS X
bitness:
64-bit
hardware architecture:
amd64/x86

Description

As soon as you click on "Add brush", from the mask manager or from a module, Darktable freeze juste after showing the brush handle into the picture (as visible on the included screenshot).

Thank
Anthony.

Capture d’écran 2015-02-08 à 12.27.51.png - Add brush screenshot (1.3 MB) Anthony hinsinger, 02/08/2015 01:54 PM

crash.log Magnifier - Crash log after kill -SEGV (89.6 KB) Christian Stussak, 09/18/2015 01:15 PM

History

#1 Updated by Igor Kuzmin over 3 years ago

  • Assignee changed from Aldric Renaudin to Igor Kuzmin

#2 Updated by Pascal Obry over 3 years ago

I cannot reproduce with development version.

#3 Updated by Pascal Obry over 3 years ago

BTW, have you tried with 1.6.2?

#4 Updated by Roman Lebedev over 3 years ago

  • Subject changed from Add brush to a mask freeze Darktable to Add brush to a mask freezes Darktable

#5 Updated by Igor Kuzmin over 3 years ago

It is most likely limited to OS X. I cannot reproduce with 1.6.2 on Linux, will test 1.6.2 on OS X tomorrow.

#6 Updated by Anthony hinsinger over 3 years ago

Yes I've tested 1.6.2 on OSX and the bug is still there, I confirm the bug doesn't appear on Linux.

Anthony.

#7 Updated by Igor Kuzmin over 3 years ago

  • Affected Version changed from 1.6.0 to 1.6.2

Right, I forgot about this bug. Just tried to reproduce it on my MacBook and I couldn't - works fine for me.
Can you please run the following command in Terminal after you trigger the bug (hang darktable):
killall -SEGV darktable-bin
and post here the resulting crash log, it might shine some light on this issue. But to be honest since I can't reproduce I doubt I will be able to fix it.

#8 Updated by Christian Stussak about 3 years ago

  • File crash.logMagnifier added
  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

The bug still persists in version 1.6.8. I am going to add some more detail for debugging.

darktable -d all outputs

[masks dynbuf 'brush dpoints'] with initial size 1000000 (is 0x175ba7000)
[masks dynbuf 'brush dborder'] with initial size 1000000 (is 0x175f78000)
[masks ] brush_points init took 0,0000 sec
[masks dynbuf 'brush dpoints'] freed (was 0x0)
[masks dynbuf 'brush dborder'] freed (was 0x0)
[masks ] brush_points point recurs 0,0000 sec
[masks ] brush_points transform took 0,0000 sec

right before freezing. The crash log is attached.

If you need more details, please let me know.

I would really love to see this bug fixed. Some plugins like the blur plugin are kind of useless without brushes ...

BTW: after reopening darktable, a brush has been added to the mask. It is also possible to edit the mask via the control points afterwards, but adding a additional brush just freezes darktable again.

#9 Updated by Igor Kuzmin about 3 years ago

Still can't reproduce... Please wait for 1.6.9 release and retest. Just a guess - try deactivating OpenCL also.

Also available in: Atom PDF