Project

General

Profile

Bug #10277

Cannot export style containing slash character

Added by Victor Lamoine about 5 years ago. Updated about 5 years ago.

Status:
Fixed: To be cherry-picked
Priority:
Low
Assignee:
-
Category:
Lighttable
Target version:
-
Start date:
01/10/2015
Due date:
% Done:

90%

Estimated time:
Affected Version:
1.6.1
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Export a style named "Canon FD 50mm f/1.4" fails because of the slash character.
Either darktable should forbid these characters in style names or handle them properly.

Associated revisions

Revision 5bfd8800 (diff)
Added by Ulrich Pegelow about 5 years ago

styles export: replace slash by underscore in filename; fixes #10277

needs to be documented in next release of usermanual

Revision 2136d7cd (diff)
Added by Ulrich Pegelow about 5 years ago

styles export: replace slash by underscore in filename; fixes #10277

needs to be documented in next release of usermanual

(cherry picked from commit 5bfd8800d31238e17a7e48b4877a3dfdd05ec23f)

History

#1 Updated by Ulrich Pegelow about 5 years ago

  • Status changed from New to Closed: invalid

The slash character is a special one on all unix filenames and is only allowed as a separator between (sub)folders and filename.

Nothing special here with darktable.

#2 Updated by Ulrich Pegelow about 5 years ago

  • % Done changed from 0 to 10
  • Status changed from Closed: invalid to Confirmed

Re-opened. The bug report is right. darktable auto-generates filenames for style export from the style name which allows the slash character as valid. We should repace slashes with an underscore for style exports. Any other character which might cause problems?

#3 Updated by Ulrich Pegelow about 5 years ago

  • % Done changed from 10 to 90
  • Status changed from Confirmed to Fixed: To be cherry-picked

#4 Updated by Victor Lamoine about 5 years ago

Ulrich Pegelow wrote:

Re-opened. The bug report is right. darktable auto-generates filenames for style export from the style name which allows the slash character as valid. We should repace slashes with an underscore for style exports. Any other character which might cause problems?

I don't think so, I tested the following characters without having any problems:

\?%*:|"'`<>.

#5 Updated by Ulrich Pegelow about 5 years ago

It seems to be generally recommended to avoid filenames with characters <>: "\ / | *?

So we should better replace those as well.

#6 Updated by Victor Lamoine about 5 years ago

Ulrich Pegelow wrote:

It seems to be generally recommended to avoid filenames with characters <>: "\ / | *?

So we should better replace those as well.

$ should also be avoided (system variables)

Also available in: Atom PDF

Go to top