Project

General

Profile

Bug #10177

HDRMerge DNG-format

Added by Bert Blockx over 4 years ago. Updated over 2 years ago.

Status:
Fixed
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
Start date:
10/27/2014
Due date:
% Done:

100%

Affected Version:
git development version
System:
all
bitness:
64-bit
hardware architecture:
amd64/x86

Description

I am unable to open DNG files from HDRMerge in Darktable 1.4.2 (stable) and Darktable 1.5+2075~g09042e3 (unstable).
The unstable version complains about camera whitebalance.
HDRMerge writes DNG SDK v1.4 files with 16, 24 and 32 bits per pixel
HDRMerge can be found here:
http://jcelaya.github.io/hdrmerge/
https://github.com/jcelaya/hdrmerge
I have attached an example of a 16bit DNG file.

This is probably the same problem as with the program 'CeroNoise' as pointed out by Josep V. Moragues.
CeroNoise can be found here:
http://www.magiclantern.fm/forum/index.php?topic=9581.0
A sample of a 32bit DNG from CeroNoise can be downloaded here:
https://www.dropbox.com/s/4n1ir60r9r8gpzb/ceronoice_HDR_32bit_float.dng?dl=0

2014-10-19 @15-40-59 WK5S1542-1544.dng (17.2 MB) Bert Blockx, 10/27/2014 10:22 PM


Related issues

Related to darktable - Bug #10545: 'Create HDR' leads to broken DNG files Confirmed 06/20/2015

Associated revisions

Revision 6917bee1
Added by Roman Lebedev over 2 years ago

Rawprepare iop: support HDRMERGE fp unnormalized DNG's. Fixes #10177.

Let's hope that we never encounter normalized fp dng's :)

History

#1 Updated by Roman Lebedev over 4 years ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10
  • Affected Version changed from 1.4.2 to git development version
  • System changed from Ubuntu to all

darktable from git:
[rawspeed] DNG Decoder: No RAW chunks found
[temperature] failed to read camera white balance information!

#2 Updated by Christian Stussak almost 4 years ago

I can confirm this bug. It looks like darktable 1.6.7 is still unable to load the DNG 1.4 floating point formats (16 bit, 24 bit, 32 bit). Hence, this is not specific to HDRMerge or the other tool you pointed out. I opened the DNG files created by HDRMerge on a friends Windows system using the Adobe DNG Codec which I assume to be a good test authority. This worked well and hence I assume, that the DNG files created by HDRMerge are valid.

Maybe we can raise the priority of this issue since it seems to affect the DNG format in general and not just the files created by a specific program. The title might also be changed to something like Add support for DNG 1.4 or something (if someone can confirm that this is the actual issue).

Frankly, there seems also to be a problem with the HDR DNG files that are CREATED BY darktable. I cannot open them with any other of my tools. Neither with RawTherapee (which loads the DNG linked above correctly), nor with the Adobe DNG Codec. But maybe that's a topic for another issue.

#3 Updated by Tobias Ellinghaus almost 4 years ago

  • Assignee set to Pedro Côrte-Real
  • % Done changed from 10 to 20
  • Status changed from Confirmed to Triaged
  • Category set to Darkroom

In theory this should be "Closed: upstream" since it's a missing feature in rawspeed, namely opening of Deflate compressed DNGs. However, since much work on rawspeed is done in our tree by Pedro I will leave it to him how to proceed with this bug.

The thing about our HDR DNGs not being compatible with other applications is known. See #10545.

#4 Updated by Tobias Ellinghaus almost 4 years ago

  • Related to Bug #10545: 'Create HDR' leads to broken DNG files added

#5 Updated by Roman Lebedev over 2 years ago

  • Status changed from Triaged to In Progress
  • Assignee deleted (Pedro Côrte-Real)
  • % Done changed from 20 to 50

rawspeed part is merged.
darktable part is TODO.

#6 Updated by Roman Lebedev over 2 years ago

  • % Done changed from 50 to 100
  • Status changed from In Progress to Fixed

#7 Updated by Roman Lebedev over 2 years ago

  • Target version set to 2.4.0

Also available in: Atom PDF