Project

General

Profile

Bug #10164

Darktable wrongly reports lock PID as being alive on the system

Added by Luca Pireddu about 3 years ago. Updated 11 days ago.

Status:
Closed: invalid
Priority:
Low
Assignee:
-
Category:
General
Target version:
-
Start date:
10/15/2014
Due date:
% Done:

0%

Affected Version:
1.4.2
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Darktable was killed disgracefully on my system (kernel panic and system crash). As a result, its lock file is left behind under @${HOME}/.config/darktable/library.db.lock.

Now darktable fails to start saying that

[init] the database lock file contains a pid that seems to be alive in your system: 3605
[init] database is locked, probably another process is already using it

But that PID currently doesn't exist on my system:

[ilveroluca@pear darktable] ps aux | grep -w 3605
pireddu  20767  0.0  0.0  19580   952 pts/2    S+   21:16   0:00 grep -w 3605

That message is inaccurate and darktable should start.

History

#1 Updated by Tobias Ellinghaus about 3 years ago

  • % Done changed from 0 to 20
  • Status changed from New to Incomplete

Maybe it existed when it looked? Can you reproduce that dt is seeing non-existing processes? You could try to manually write a PID into the lock file that is not existing and try again.

#2 Updated by Luca Pireddu about 3 years ago

  • % Done changed from 20 to 0
  • Status changed from Incomplete to Closed: invalid

You must be right. I can't reproduce the problem any more.

#3 Updated by Gregoire Welraeds about 2 years ago

$ sudo ps aux | grep 3453
4418 0.0 0.0 9764 2336 pts/2 S+ 10:20 0:00 grep --color=auto 3453
$ darktable
[init] the database lock file contains a pid that seems to be alive in your system: 3453
[init] database is locked, probably another process is already using it

Ubuntu 15.04, this is darktable 1.6.2

I believe dt was shutdown normally the last time I have used it (yesterday)

#4 Updated by Gregoire Welraeds about 2 years ago

~/.config/darktable$ cat library.db.lock
3453

So this is the id of yesterday process... But for some reason when starting darktable, it believes there is a running process under that pid, which is not true.

#5 Updated by Tobias Ellinghaus about 2 years ago

Not sure what is happening there. Does /proc/3453/ exist? If there is no running darktable process it is safe to just delete ~/.config/darktable/library.db.lock.

#6 Updated by michael soluyanov 11 days ago

Same bug in ubuntu 16.04. rm ~/.config/darktable/library.db.lock solve problem

Also available in: Atom PDF