Project

General

Profile

Bug #10069

Darktable forgets image target attributes and deletes thumbnails

Added by Jeb Eldridge about 5 years ago. Updated almost 5 years ago.

Status:
Incomplete
Priority:
Low
Assignee:
-
Category:
Darkroom
Target version:
Start date:
08/20/2014
Due date:
% Done:

20%

Estimated time:
Affected Version:
1.4.2
System:
Ubuntu
bitness:
64-bit
hardware architecture:
amd64/x86

Description

After a few days of use, Darktable has begun forgetting image attributes when I restart my computer and boot up the program, leading to pages full of broken links and "dead" thumbnails, making the application useless.

My Darktable version is 1.4.2 on Ubuntu 14.04.1 with NVidia GPU and AMD Phenom II X4 CPU. Darktable is push-updated to me via the official PPA.

Screenshot from 2014-08-17 12_57_52.png (464 KB) Screenshot from 2014-08-17 12_57_52.png Broken image attributes Jeb Eldridge, 08/20/2014 03:07 PM

History

#1 Updated by Pascal de Bruijn about 5 years ago

  • Target version changed from Candidate for next patch release to Future
  • Priority changed from Medium to Low

Did you by any chance delete or move files to a different location outside of Darktable?

When you import images into Darktable, darktable saves their location in it's database. When those locations go missing, darktable will tell you stuff is missing, as it should.

If you moved the .xmp files along with the RAW files, you should be able to import them at their new location and get any edits back via the .xmp's. (the xmp's are essentially mini backups of the image specific data in the darktable database).

You can use this script to cleanup your database:
https://github.com/darktable-org/darktable/blob/master/tools/purge_non_existing_images.sh

Please let us know if the above covers your case.

#2 Updated by Pascal de Bruijn almost 5 years ago

  • % Done changed from 0 to 20
  • Status changed from New to Incomplete

Please let us know if the information above helped.

Also available in: Atom PDF

Go to top