Project

General

Profile

Feature #10053

collect module: date comparisons

Added by Dieter Plaetinck over 5 years ago. Updated about 5 years ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
08/11/2014
Due date:
% Done:

0%

Estimated time:
Affected Version:
git stable branch
System:
other GNU/Linux
bitness:
64-bit
hardware architecture:
amd64/x86

Description

Hi,
first of all DT is a great piece of software. Thanks a lot for it!
One thing i noticed, it seems like you can only do pattern matching on date and time fields in the collect module, this is a bit limiting.
I would love to be able to do something like "date > 2014-07-19" and "date < 2014-08-04" if i want to work on a photo album of my vacation for example, and I know that all the pictures I need are in a given date range. Especially since I shot a lot of other pictures in 2014-07, they clutter up the lighttable, i need to wait for the thumbs to load, etc. Being able to compare dates instead of just pattern matching would be great.


Related issues

Is duplicate of darktable - Feature #8587: >=, <= operators in "collect images" filtersTriaged

History

#1 Updated by Roman Lebedev over 5 years ago

  • Is duplicate of Feature #8587: >=, <= operators in "collect images" filters added

#2 Updated by Roman Lebedev over 5 years ago

  • Status changed from New to Duplicate

#3 Updated by Christian iuga about 5 years ago

For me it's not excalty a duplicate of Feature #8587

Now (from version 1.4) we can use operators like >=, <= in "collect images"
It's work like a charm for ISO & aperture (so the main feature of #8587 is fixed)

But it's doesn't work for date and time
So, a minima the #8587 should be update :
done for ISO & Aperture
Need work on date

Also available in: Atom PDF

Go to top